Clipper On Line • Ver Tópico - Erro hBrowse com array

Erro hBrowse com array

Projeto HwGui - Biblioteca visual para Harbour/xHarbour

Moderador: Moderadores

 

Erro hBrowse com array

Mensagempor gilbertosilverio » 19 Set 2021 06:53

Ola Amigos,

Nunca usei, ontem quando tentei usar um combobox na célula de hbrowse, ocorre esse erro.


Error BASE/1005  Message not found: HCOLUMN:_AITEM
Called from ->__ERRRT_SBASE(0)
Called from ->HCOLUMN:ERROR(0)
Called from ->(b)HBOBJECT(0)
Called from ->HCOLUMN:MSGNOTFOUND(0)
Called from ->HCOLUMN:_AITEM(0)
Called from pcode.hrb->TEST(27)
Called from ->HB_HRBRUN(0)
Called from ->RUNSAMPLE(332)
Called from ->(b)MAIN(122)
Called from ->HTREE:NOTIFY(354)
Called from ->ONNOTIFY(276)
Called from ->(b)(_INITSTATICS00005)(0)
Called from ->HWINDOW:ONEVENT(201)
Called from ->HMAINWINDOW:ONEVENT(419)
Called from ->HWG_ACTIVATEMAINWINDOW(0)
Called from ->HMAINWINDOW:ACTIVATE(400)
Called from ->MAIN(145)

HWGUI 2.23 dev Build 1
Date:09/19/21
Time:06:24:23



Na 2.17, se mudo AITEM para ALIST, funciona, mais na 2.23 não da erro de execução e o sistema fecha.

6E820000 00210000 C:\WINDOWS\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.19041.1110_none_a8625c1886757984\comctl32.DLL

Called from HWG_COMBOADDSTRING(0)
Called from HCOMBOBOX:INIT(148)
Called from HWG_INITCONTROLS(41)
Called from INITMODALDLG(271)
Called from (b)(_INITSTATICS00003)(0)
Called from HDIALOG:ONEVENT(214)
Called from HWG_DLGBOXINDIRECT(0)
Called from HDIALOG:ACTIVATE(159)
Called from HBROWSE:EDIT(1976)
Called from HBROWSE:BUTTONDBL(1757)
Called from HBROWSE:ONEVENT(423)
Called from HWG_DLGBOXINDIRECT(0)
Called from HDIALOG:ACTIVATE(159)
Called from TEST(35) in pcode.hrb
Called from HB_HRBRUN(0)
Called from RUNSAMPLE(332)
Called from (b)MAIN(122)
Called from HTREE:NOTIFY(354)
Called from ONNOTIFY(276)
Called from (b)(_INITSTATICS00005)(0)
Called from HWINDOW:ONEVENT(201)
Called from HMAINWINDOW:ONEVENT(419)
Called from HWG_ACTIVATEMAINWINDOW(0)
Called from HMAINWINDOW:ACTIVATE(400)
Called from MAIN(145)


Ja no BROWSE DATABASE, funciona com aITEM normalmente.

Na 2.17 deixo com esta na imagem, funciona, mais na 2.23 da o erro acima.

Se puderem informa, tentei no HWGUI mais não tenho acesso a reportar bugs.
Anexos
T1.png
gilbertosilverio
Usuário Nível 3

Usuário Nível 3
 
Mensagens: 308
Data de registro: 18 Jan 2009 09:39
Cidade/Estado: Ribeirao Pires - SP
Curtiu: 0 vez
Mens.Curtidas: 19 vezes

Erro hBrowse com array

Mensagempor JoséQuintas » 19 Set 2021 11:53

gilbertosilverio escreveu:Se puderem informa, tentei no HWGUI mais não tenho acesso a reportar bugs.


Pra reportar problema precisa ter uma conta no sourceforge, NÃO na HWGUI, mas no sourceforge mesmo.
José M. C. Quintas
Harbour 3.4, mingw, gtwvg, multithread, dbfcdx, ADO+MySql, hbnetio, PNotepad
"The world is full of kings and queens, who blind our eyes and steal our dreams Its Heaven and Hell"
Avatar de usuário

JoséQuintas
Colaborador

Colaborador
 
Mensagens: 17694
Data de registro: 26 Fev 2007 11:59
Cidade/Estado: São Paulo-SP
Curtiu: 13 vezes
Mens.Curtidas: 956 vezes




Retornar para HwGui

Quem está online

Usuários vendo este fórum: Nenhum usuário registrado online e 3 visitantes


Ola Amigo, espero que meu site e forum tem lhe beneficiado, com exemplos e dicas de programacao.
Entao divulgue o link da Doacao abaixo para seus amigos e redes sociais ou faça uma doacao para o site forum...
MUITO OBRIGADO PELA SUA DOACAO!
Faça uma doação para o forum
cron
v
Olá visitante, seja bem-vindo ao Fórum Clipper On Line!
Efetue o seu login ou faça o seu Registro